Restoring Mid 2009 White Macbook [Experience][Solved]

Discuss any version of the Mac OS.
Post Reply
User avatar
Posts: 3
Joined: Mon Mar 26, 2018 1:28 am
Location: Hell

Restoring Mid 2009 White Macbook [Experience][Solved]

Post by Crowley » Mon Mar 26, 2018 2:36 am

This Post is here to be educational,I would like to share my experience so that others may improve upon it. This is NOT a guide.
Not exactly sure where this post goes as it does contain hardware and software topics.
I got an old 2009 white macbook a while back. I didn't bother with it for a bit because it was causing nothing but problems. I knew nothing about laptops, let alone a macbook. I have not found any other posts about this, probably my own fault though.
I've been trying to fix the macbook.
I learned some stuff and tried.
It had the following problems:
Bad HDD [Replaced]
Bad ODD [Fixed]
Overheating [Thermal Paste replaced]
Bad/Old Inverter Cable [Replaced]
Covered in unknown black residue [Broke the keyboard]
The macbook that is being tinkered with is a Mid 2009 White Macbook 5,2 A1181 ... specs.html
IFixIt provides well made guides to getting into a macbook.
The Start: An OS
No OS was found on the original HDD, what was prompted was a OS 10.10 installation but required an apple id with it already owned. This is my first apple computer, so no can do.
After checking the HDD for any errors on ubuntu, i chucked it to the side and used an extra laying around.
Installing OS 10.6 then 10.6.8 [installed just fine but turned off randomly due to over heating and the keyboard]
How do I know it was the keyboard? Carefully watch for any shut down prompts. I was lucky enough to catch the macbook trying to turn itself off. I was asked about wanting to shut it off while clearly I was just looking at the desktop.
Installing Windows 10
Installed perfectly from usb, no flaws. Played games perfectly.
Had a 9800GT for my pc to know what to be expecting from the 9500GT.
Installing El Captain [Failed] - Continued
If you need a clean installation of 10.11 El Captain, Apple offers it here:
Requires the app store Image
It didn't install at all. It gets stuck at 8 minutes then the computer freezes or displays an error with the log sharing little to nothing.

The internals: Inverter, ODD, and Heatsink
The screen was darker than I would expect, and some lines showed at boot. I knew the inverter cable was doomed. Clearly destroying the output, replaced it and it went back to normal.
The ODD was a mess though, it sounded like a wood chipper too.

Opening the macbook, the SuperDrive looked perfect. Still had the warranty sticker on it. Opening the drive and plugging it back in made it function fine. It not only could read disk, it booted off a live linux disk. So It worked. Placed the top back on.
Taking off the heatsink was annoying but it revealed how neglected this mac was. I noticed small black dust around the insides and the thermal paste was pretty much non existing. Had to replace that but macbook's airflow suck anyways.

I knew the keyboard was a mess but it introduces problems:
Airflow issues
Bad power button.
The way i found out the airflow issues and the power button issue was that I let the mac sit on 10.6 without the keyboard on. It didn't turn off randomly with a prompt and the fans never went crazy.
To make sure about the heat too, I plugged it back in but not putting it in place. I left it on the selection screen for a long time and it the fans were fine and it did not turn off.

Getting El Captain on this junk
I've tried 2 more times to get el captain on the machine, both being a big waste of time.
I had an idea though.
These ideas are based off assumptions though, if you know what the true reason is, please tell!
I thought snow leopard was leaving it in an uninstallable environment. So I installed el captain onto a USB drive. Hell it took forever but it worked.
They installed differently too. As the USB installed straight up from the start up screen, installing from snow leopard provided a UI as if booting into recovery tools. Already a difference
My plan is to copy the USB to the HDD.

Post will be updated with how that goes.

Cloning the USB WENT ALMOST PERFECT! Cloned without problem and 10.11 ran just fine, but 1 problem.
I did not clone it right. only 16 GB was being used on the HDD for the entire installations. Trying to fix it, update soon.
Last piece is a new keyboard.

Kernel Panics show when attempting to use recovery tools from USB. Still unable to find solution to the space problem. Tried recovery tools and linux.
Tried 5 times to boot into the USB's recovery tools which resulted in kernal panics. The issue was solved though by the following:
So i just reset the entire hard drive then made two partitions. Then tried to get into the recovery partition from the USB, which I already tried, so I had to start el captain from the USB, then from there I got it to start in recovery.
I "recovered" the first partition with el captain to the 2nd partition, which had the extra unused 400GB+ and it went PERFECT!! I'm keeping the first partition as a backup.
The Macbook now has a new OS. As the issues are solved, the keyboard is missing. Won't be a complete restoration till that. Will update in the future.

Side Note:
The original HDD actually isnt a problem, ain't that something?? I'm even using it for a hackintosh. A New HDD wasnt even needed.
Post Reply